Customizing Toolbars


Reference Number: KB-00811
Last Modified: February 17, 2020

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors

Home Designer Professional



QUESTION

How can I customize my toolbars to improve my workflow?


ANSWER

You can increase your productivity by customizing various settings relating to your toolbars. This article will explain how, including:


Creating and switching between custom toolbar configurations

  1. Launch Chief Architect and create a New Plan


  2. Select Tools> Toolbars and Hotkeys> Customize Toolbars  from the menu.

    In Home Designer Pro, navigate to Tools> Toolbars> Customize Toolbars .


  3. On the Configurations panel of the Toolbar Customization dialog that displays: 

    Copy a configuration to create a custom toolbar configuration

    • Click on a configuration in the list that is most similar to the custom configuration that you would like to create. 

    • With a configuration selected, click the Copy button. 


  4. In the New Toolbar Configuration File dialog: 

    Name the new toolbar configuration

    • Type a short, descriptive name for your new configuration, then click OK.   

    • Your new configuration is added to the Toolbar Configuration list and is also specified as the new Active Configuration.  


  5. Select the configuration you would like to have active from the list and use the Switch To button to change to it. When you click the Close button, your new configuration will be in use.

    You can also switch configurations using the toolbar buttons or by right-clicking any toolbar and selecting the configuration under Toolbar Configurations.


  6. With your new toolbar configuration active, make any desired changes to the program toolbars. 

    • Existing toolbars can be moved so that they dock to the top, bottom or either side of the Chief Architect program window, or they can float within the view window. 

    • You can add or remove buttons on existing toolbars or create entirely new toolbars using the Customize Toolbars dialog. 

    • You can customize the toolbars in all views - not just floor plan view. 


  7. When you are satisfied with the organization of your toolbars, select File> Exit from the menu to close Chief Architect completely.  

    • Closing the program will save your changes to the toolbar configuration made during this program session in the .toolbar file created in Step 4, above. 

    Note: It is recommended to make backup copies of your custom toolbar configurations by saving it on to a network server, USB flash drive, CD or DVD. The Toolbars folder is in the Chief Architect Data folder, located by default, in your Documents directory.

If you have made changes to an existing toolbar configuration, such as the Default Configuration, it is a good idea to make a copy of it. Creating a custom copy will help you protect your customization's should you need to reinstall the program or restore your toolbar defaults.



Creating custom toolbars

  1. Select Tools> Toolbars and Hotkeys> Customize Toolbars  from the menu.

    In Home Designer Pro, navigate to Tools> Toolbars> Customize Toolbars .
     

  2. On the Tools panel of the Toolbar Customization dialog, select an option from the list of Views.

    • Your selection will determine not only what buttons are available in the Toolbar Buttons list, but also what view types your custom toolbar will be present in.

      Select the view type to see the different available buttons


  3. Still on the Tools panel, browse the list of Available Toolbar Buttons and click on a toolbar button that you would like to add to your custom toolbar.

    • A description of the tool's use displays under the available buttons list.

    • If the selected button is a Parent Tool you will see a small arrow Parent tool drop down arrow icon displayed to the left of the name which can be used to expand the list of associated Child tools. 

    Note: If you are still unable to locate a particular tool, it may be that the feature you are looking for is actually an Edit tool, which will only be available on the Edit Toolbar when it can be applied to a selected object. 

  4. Click on a button in the list, hold down your left mouse button and drag the selected button outside of the Toolbar Customization dialog box.

    • If you drag the toolbar button to an existing toolbar, the button will be added to that toolbar when you release your mouse button.

    • If you drag the toolbar button into the drawing area, a new toolbar will be created and the button will be placed in that toolbar.

      Creating a new undocked toolbar

    • This toolbar can be dragged and docked to the top, bottom or side of the Chief Architect drawing area, or it can remain floating.

    • Similarly, you can dock or undock existing toolbars to customize their locations as you wish at any time.


  5. Continue adding toolbar buttons to your new toolbar as desired.

    Custom undocked toolbar with multiple buttons


  6. To remove an item from the toolbar, click and drag the item from the toolbar and drop it into the Toolbar Customization dialog.


  7. To rename the toolbar, select the Toolbar panel of the Toolbar Customization dialog, select the toolbar from the list, and then click once on the name to rename it.

    Toolbars can be renamed in the toolbar customization dialog.


  8. Also on the Toolbar panel, you can choose which views you wish to see this toolbar by, by simply placing a check mark in the appropriate columns.


Using the Place Library Object tool*

*Applies to Chief Architect Premier and Chief Architect Interiors.

The Place Library Object  tool can be added to the toolbar and customized to place a symbol from the library.

  1. Place the Place Library Object  tool on a toolbar by dragging it from the Toolbar Customization dialog on to the toolbar of choice.

    Find the Place Library Object tool in Toolbar Customization and drag it on to a toolbar to use it.


  2. Click the Close button to close the dialog.


  3. Using the Select Objects  tool, click the Place Library Object tool that was just placed to open the Library Object Button Specification dialog box.


  4. Click the Library button to open the Select Library Object dialog.

    Changing the library object for the library object specification.

    • Navigate through the library to the symbol you want to place using this tool. 

    • In this example, we have selected the Composting Toilet.

      Select library object dialog choosing the composting toilet


  5. Click OK to return to the Library Object Button Specification dialog, then click OK again to return to your plan.

This tool is now linked to the Composting Toilet symbol located in the library and can be selected anytime to place this object in your plan.


Using the Child Tool Palette setup

  1. Launch Chief Architect and create a New Plan 


  2. Select Edit> Preferences  if you're on a Windows PC or Chief Architect> Preferences if you're on a Mac.


  3. Select the Appearance panel of the Preferences dialog, and under the Toolbars section, move the radio button to Child Tool Palette, then click OK.

    Select Child Tool Palette button in Preferences to switch from dropdowns

    Note: If the Tool Palette doesn't open automatically, navigate to View> Tool Palette from the menu.


Changing the toolbar button size

  1. Select Edit> Preferences  from the menu if you're on a Windows PC, or Chief Architect> Preferences if you're on a Mac.


  2. On the Appearance panel of the Preferences dialog, under the Toolbars section, change the value to the right of the Button Size field, then click OK. The higher the value entered here, the larger the Toolbar buttons will be.

    In this example, the Button Size was changed from 20 pixels to 40 pixels.

    Button sizes can be changed in Preferences to be larger or smaller.


  3. When you relaunch the program, the change in button size will take effect.

    See how the buttons get larger when the button size is changed.

    Note: Increase the toolbar button size may result in tools no longer fitting on your toolbar. Such toolbar buttons can be viewed by clicking on the double arrow icon on the far right of the toolbar.