Creating Roof Trusses


Reference Number: KB-00981
Last Modified: May 23, 2017

The information in this article applies to:

Chief Architect Premier


QUESTION

How do I create a roof truss?


Vector view of roof trusses


ANSWER

Drawing roof trusses in Chief Architect is as simple as drawing and replicating a line - as long as certain conditions are met.  Roof trusses in the program are defined by the position of one or more roof planes above and one or more ceilings below, so both must be in place before a truss is drawn.

  • The roof and ceiling planes can be automatically generated or manually drawn.   

  • The ceiling can be composed of the default flat ceiling generated in each room by default, of manually-drawn planes created using the Ceiling Plane tool, or of a combination of the two.  

  • There must be space between the roof and ceiling in which a truss can generate. Trusses cannot be generated along the line where the roof and ceiling come together, usually on a bearing wall.


To create roof trusses

  1. Open the plan in which you would like to create roof trusses, or select File> New Plan  to open a new plan.   



    • In this example, a simple 20' x 30' plan is used.  


  2. With the Select Objects  tool Group Select the left and right walls. Next click Open Object .


  3. In the Wall Specification, on the Roof panel put a checkmark next to Full Gable Wall and click OK.




    For additional information on building an automatic Gable roof visit the "Generating Automatic Hip and Gable Roofs" article linked in the Related Articles section.


  4. From the menu select Build> Roof> Build Roof .

    • On the General panel put a checkmark next to Build Roof Planes

    • Put a checkmark next to Trusses (no Birdsmouth)

    • Verify pitch and overhang settings and then click OK.
      For this article an 8:12 pitch is used and an 18" overhang.



      The Trusses (no Birdsmouth) setting sets the roof height so that the bottom edge of the truss top chord is flush with the top of the wall and roof plane thickness is based on the default Top Chord Depth set in the Framing Defaults.  If it is not checked, the roof plane thickness is determined by the rafter Depth setting in the Framing Defaults.

      If you plan to use both trusses with rafters, leave Trusses (no Birdsmouth) unchecked so that the rafters’ depth can be accommodated. Please review the "Mixing Trusses with Stick Framing" section of the Reference Manual for more information.


  5. Select Build> Framing> Roof Truss  from the menu, then click and drag a line at a location where you would like a roof truss. 

    • A Message may appear asking "Do you want to turn on the display of the "Framing Roof Trusses" layer." Click Yes to display the Roof Trusses layer in this view.




     


To replicate trusses across a structure

  1. Move the first truss into position using Temporary Dimensions.

    • Make sure that Temporary Dimensions  are enabled. If they are not, you can enable them by selecting View> Temporary Dimensions .

    • Click the Select Objects  button, then click on the truss to select it. 

    • If you select a roof plane, ceiling plane, or other object instead of the truss, click the Select Next Object  edit button or press the Tab Key on your keyboard until the truss is selected. 

    • When the truss is selected, a dimension will depict how far it is from a perpendicular wall.  Click on the dimension, type 0" in the text field, and press Enter.


    • The truss will move so that its outer edge is aligned with the outer edge of the framing layer of the wall.




  2. With the truss still selected, click the Multiple Copy  edit button.  


  3. By default, the Multiple Copy interval for trusses is 24" (600 mm). To change this interval, click the Multiple Copy Interval  edit button and specify the desired Primary Offset value for trusses in the Multiple Copy dialog, and then click OK.  




  4. Click and drag the truss's middle Move  edit handle towards the other end of the structure.  As you drag, new trusses will be created at regular intervals. Release the mouse button to complete the command.  

     

  5. Select 3D> Create Perspective View> Perspective Framing Overview  to see the results.  

To create a reduced gable or an end truss

  1. With the Select Objects  tool select the trusses on either end of the gable and then click Open Object .

    Holding the Shift key while selecting allows you to group select multiple trusses.


  2. In the Roof Truss Specification dialog, on the General panel,  put a checkmark next to End Truss as well as Force Truss Rebuild.

    • Check Reduced Gable in this dialog as well to lower the top chord of an End Truss so that lookouts can pass over the truss.

    • Click OK to regenerate the Truss


  3. Select 3D> Create Perspective View> Perspective Framing Overview  to see the results.