Using Real World Elevation Data to Create a Terrain


Reference Number: KB-01078
Last Modified: March 1, 2019

The information in this article applies to:

Premier



QUESTION

I have the elevation data for my latest building project, as measured from sea level. How can I use this data in my Chief Architect plan?

Overview of green terrain with hills and valleys


ANSWER

By default, Chief Architect will automatically create a flattened building pad below a structure, and will choose a height for the building pad based on the terrain elevation at the structure's center point. In some situations, however, this automatic behavior can't be used - for example, in the case of a walkout basement.

Before entering your terrain data, change the terrain settings to avoid having the house float too low or too high in the terrain. 


To set the terrain at a specific elevation

  1. If you have not done so already, select Terrain> Create Terrain Perimeter from the menu to create a terrain perimeter in the plan.

    Note: In most cases, the Terrain Perimeter should be located on Floor 1. 

  2. Select Terrain> Terrain Specification from the menu to open the Terrain Specification dialog. 


  3. On the General panel under Building Pad:

    Adjusting the Subfloor Height Above Terrain value in the Terrain Specification dialog.

    • Remove the check from the Automatic box.

    • Set the Subfloor Height Above Terrain value to your liking.

      For more information, click on the Help button located at the bottom of the dialog box.

      To gain a better understanding of how terrain height works in Chief Architect, please navigate to Help> Launch Help within your program and search: Terrain Perimeter.

    • Click OK to confirm the change and close out of the dialog.


  4. Next, create two elevation lines in the plan equal to the subfloor height above terrain value that was specified in the previous step:

    • Select Terrain> Elevation Data> Elevation Line from the menu, then click and drag to draw an elevation line.

    • Click on the line to select it, then click the Open Object edit button. On the Elevation panel of the Elevation Line Specification dialog, set the Elevation at 100' and click OK.

      Elevation value for an elevation line

    • With the elevation line still selected, click the Copy/Paste edit button, then click and drag the line's Move edit handle away from the line's location. Release the mouse button to create an identical copy of the elevation line.


    Creating two elevation lines at the same elevation will create flat terrain at that height.


  5. At this point, you can delete the two elevation lines and then either draw, or import the actual elevation data that you intend to use to generate your terrain. 


Importing terrain or elevation data

Chief Architect supports several different methods for importing terrain and elevation data:

  • Elevation data saved in a text file format can be imported by selecting File> Import> Import Terrain Data from the menu. Elevation data that is saved in this format is usually done with the x, y, and z coordinates in mind, where x and y define the location of a point on a Cartesian grid, and z defines the elevation for the point. When using this import method, each data point must be on a separate line in the text-based file.

    For more information, navigate to Help> Launch Help within your program, and search: Import Terrain Assistant.

  • GPS data in a .gpx file format can be imported by selecting File> Import> Import GPS Data .GPS data may include three types of points - Way, Track and Route. Chief Architect can only import a .gpx file if it includes one or more Way Points. If a *.gpx file is imported and it contains no Way Points, no data will be imported. Route Points contained in a .gpx file will not be recognized upon importing.

    For more information, navigate to Help> Launch Help within your program, and search: Import GPS Data Assistant.

  • Elevation data can also be imported in .dxf or .dwg format using the Import Drawing Assistant by selecting File> Import> Import Drawing (DWG, DXF)  .  When importing a .dxf or.dwg file containing terrain or elevation data, specific layers have to be designated as such.

    For more information, navigate to Help> Launch Help within your program, and search: Importing DXF/DWG Elevation Data or see the Related Articles section below.