Showing the As-Built in a Remodel Plan


Reference Number: KB-02208
Last Modified: March 31, 2017

The information in this article applies to:

Chief Architect Premier


QUESTION

I am working on an addition for a remodel project, is there a way that I can show the walls for the as-built structure compared to the new proposed walls in the same plan?

You can create a CAD mask to represent your as-built condition


ANSWER

A great way to show the as-built condition on a remodel project is to create an "As-Built Mask" using a CAD block of the existing structure.

To have the CAD detail only contain the necessary items, turn off the layers of any items unnecessary to the remodel. For example, furniture, cabinets, window labels, and roof planes. Also, a new layer needs to be created for the as-built mask.

Play button icon If you would like to learn more about using Chief Architect for remodeling, please see these online tutorial training videos.



To setup your layers

  1. Click Tools> Layer Settings> Display Options Layer Display Options icon.


  2. In the Layer Display Options dialog, use the Layer Sets drop-down menu to choose the All Off Set.


  3. Click Copy Set to make a copy of the All Off Set.


  4. In the New Layer Set dialog, specify a Name for this layer set. In this example we used As-Built Mask Set then click OK.

    New Layer Set dialog


  5. Make sure As-Built Mask Set is selected in the Display Options and then turn on any layers that you want to see in the As-Built Mask.

    Layer Display Options dialog

    In our example, we enabled the following layers:

    • Doors

    • Stairs & Ramps

    • Walls, Normal

    • Walls, Main Layer Only

    • Windows


  6. Once you have turned on the layers you need, click the New button and create a new layer named CAD, As-Build Mask and click OK.


  7. Click OK to close the Layer Display Options dialog.


  8. In plan view, switch the layer set to the As-Built Mask Set by using the drop down menus on your toolbar.

    Selecting the active layer set from the toolbar.


To make a CAD Detail

  1. Center the plan on screen by selecting Window> Fill Window Building Only Fill Screen Builing Only icon.


  2. From the menu click CAD> CAD Detail From View CAD Detail From View icon to create a new CAD detail.


  3. From the menu click CAD> CAD Detail Management CAD Detal Management icon.

    CAD Detail Management dialog

    Here we can see the new CAD detail has been named Detail 1 but if there are other details in your plan, then it could receive a slightly different name.

    • Highlight the new detail and click the Rename button and rename it to As-Built Mask and click OK.

    • Click OK on the CAD Detail Management dialog to accept your changes and close it.


To adjust the line styles

  1. With the Select Objects Select Objects icon tool, click and drag a selection marquee around the CAD detail.


  2. Click the Open Object Open Object icon edit tool to open the Object Specification dialog.

    Object Specification dialog

    In this example we are adjusting the Line Options to the following:

    • Layer: CAD, As-Built Mask

    • Color: Dark Gray

    • Style: Solid Line

    • Weight: 35


  3. Click OK to apply these changes and close the dialog.

    The As-Built CAD mask with our style changes


To convert our mask into a CAD block

  1. With the Select Object Select Objects icon tool, click and drag a selection marquee around the whole detail.


  2. On the edit toolbar, click Make CAD Block Make CAD Block icon.


  3. Click Open Object Open Object icon to display the CAD Block Specification dialog.

    Note: If the CAD block disappears, this could be because you de-selected it. Turn on the CAD Default layer temporarily in the Layer Display Options to find it again.


    CAD Block Specification dialog

    • On the General panel, assign a Block Name of As-Built Mask.

    • On the Line Style panel, change the Layer to the CAD, As-Built Mask layer.

    • Under the Drawing Group, select Back.


  4. Click OK to accept your changes.


To place the CAD block

  1. Using the Select Object Select Objects icon tool, select the CAD block and then select Edit> Copy Copy icon from the menu.


  2. Switch back to the Floor Plan view.


  3. Select Edit> Paste> Paste Hold Position Paste Hold Position icon from the menu to paste the CAD block over your existing plan.


  4. Use the Active Layer Set drop-down menu again to switch back to the Default Set, or whichever layer set you prefer to work in.


  5. When walls are moved the As-Built Mask will show.

    View of the as-built walls showing the original position

    Toggle the CAD, As-Built Mask layer to show or hide the mask.


You can lock the CAD, As-Built Mask layer which will make the mask un-selectable. This makes it easier to work with the plan because the mask can no longer get in the way.