Creating and Using Layout Templates


Reference Number: KB-00737
Last Modified: July 14, 2021

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors



QUESTION

I would like to create and use a layout template in Chief Architect. How do I do this?


ANSWER

A template file has all of your preferred default settings, layer display options, and other file-specific information saved and waiting for you.

A layout template can also feature a border with your company information, logo, text macros and other details. When you identify a file as a template, Chief Architect refers to that file for this information any time you open a new layout file.

Creating a layout template is easy and can save you a lot of time when creating a new layout file.


To setup a layout template

  1. Start by selecting File> New Layout  from the menu to create a new, blank layout file.


  2. Navigate to File> Print> Drawing Sheet Setup .

    Drawing Sheet Setup dialog where the drawing sheet size, scale, and other print settings can be set

    • Set the Drawing Sheet Orientation and Size to your liking.

      In most cases, the Printer Paper and Drawing Sheet sizes should be the same.

    • Make sure the Drawing Scale is set at a 1 to 1 scale.

      Example: 1 in = 1 in

      It is important not to change this, as the drawing scale is set when you send individual views to the layout.

      For more information about drawing scale as well as line weight scaling, click the Help button at the bottom of this dialog.

    • Make any other desired changes, then click OK to apply your settings and close the dialog.


To create a layout border and title block

  1. First, go to Page 0 of the layout file.



    Page 0 is the Default Page Template. Items placed on this page show on every page of the layout that is assigned to follow this Page Template. It's possible to set up more than one page template. Please refer to the Related Articles section below for more information.


  2. Using the CAD tools, create a border and title block that you want to display on each page of the layout.


  3. Using Text or Rich Text , add a company name, project information and any other notations that you may want to display on each page of the layout.


  4. To insert a company logo, image, or PDF, select File> Import> Import Picture   or File> Import> Import PDF .


  5. Macros are special commands that insert dynamic information into a text box. After placing a text object in the layout, select the Insert Macro  tool to insert a macro.

    Text Macros are available in both plan and layout files, but are particularly useful in layouts, allowing you to automatically insert useful information such as the page number, date and time, and file name.

    Inserting the Layout Page Number macro in the Text Specification dialog

    • You can use the Layout Page Number (%page%) macro to show the page number for each page of the layout.

    • Use one of the Time or Date macros to insert the date or time in the layout to automatically let you know when you printed this layout.

    • Add the file name for this layout sheet using one of the File Info text macros.

    • Inserting this next to the binding edge will allow you to determine which file it is or even where this set of plans is located on your computer, should you need to reprint them in the future.


To save and use this file as a template

  1. Select File> Templates> Save As Template .


  2. In the Save as Template dialog that displays:

    Save as template dialog

    Note: In Chief Architect X11 and prior program versions, the ability to remove data during the template save process did not exist.

    • Check the box beside each category of object or data that you want to delete from the current file.

      Starting in X13, the Delete Objects tool can be also be used to delete specific information from one or more pages of a layout file.


    • Check Set Template as Default for Imperial/Metric Layouts to use the new template as your default template whenever you select File> New Layout .

    • Click OK.


  3. Give the new layout template a short, descriptive name.


  4. Click Save, and the program will automatically save the template to the program's Templates directory on your computer.


To change the default layout template

You can change the default layout template that is used whenever you open a new layout file by accessing the program's Preferences dialog. If the Set Template as Default for Imperial/Metric Layouts was checked in the section above, it's not necessary to follow the instructions below as you've already set your customized layout to be the default layout template.

  1. Select Edit> Preferences  from the menu if you're on a Windows PC or Chief Architect> Preferences  if you're on a Mac.


  2. On the New Plans panel of the Preferences dialog:

    New Plans panel of the Preferences dialog where Templates can be specified
     
    • Click the Browse button to the right of the Layout Template text field for the unit of measurement you're using.

    • In the dialog that opens next, browse to the location of your new layout template file, select it, and then click Open to specify this file as your default layout template.

    • Click OK to close the dialog.