Adding Detail to a Cross Section View


Reference Number: KB-00766
Last Modified: December 1, 2016

The information in this article applies to:

Chief Architect Premier

QUESTION

How can I create a detail drawing from a cross section view?  

Cross section view with added CAD details.


ANSWER

Chief Architect provides several ways to create detail drawings of your plan.

  • The Auto Detail tool is available in cross section views and quickly adds basic concrete, wall insulation and siding patterns to the view with a single click.  

  • The CAD Blocks library includes a selection of blocked detail drawings and components that can be placed in CAD Detail views and used as they are or unblocked and edited to meet your needs.  

  • Using the CAD drawing tools, you can create your own detail drawings from scratch.  


These tools and resources can be used singly or you may choose to use a combination.  For example, you could begin by Auto Detailing a cross section view.  Next, you might send the view to a CAD Detail and add a detail drawing from the CAD Blocks library.  The detail drawing can then be unblocked and edited and the CAD drawing tools used to add further information that can be superimposed on the cross section.

This article provides an overview of how to use the CAD tools to create a new foundation detail drawing, but the same tools and techniques are also helpful when editing existing drawings.  Topics discussed include:

  • Creating cross section views

  • Placing and editing components from the library  

  • Drawing components manually

  • Accurately positioning components

  • Placing details in a cross section view

  • Adding drawings to the library  

  • Show shadows in a cross section view


To create a Cross Section View

  1. In a plan file, select 3D> Create Orthographic View> Cross Section/Elevation View  or Back Clipped Cross Section  to create an elevation view.

  2. Click and drag to place the cross section camera view into the plan. Where you click sets the location that the camera is placed, while the direction you drag determines the direction the cross section view will face.


To place and edit components from the library

  1. Open a plan in which you would like to create a detail drawing and select CAD> CAD Detail Management from the menu.

     

    • In the CAD Detail Management dialog, click the New button.  

    • In the Create New CAD Detail dialog, type a descriptive New Detail Name, then click OK to close the dialog and open a new CAD Detail window.  

    • You can also send a cross section view to a CAD Detail with the cross section view open by selecting CAD> CAD Detail From View  and then you can draw detail information directly over it, but in this example we will draw the detail in a blank window we've created through the CAD Detail Management dialog.


  2. Select View> Library Browser  from the menu to open the Library Browser.     

    • Locate the CAD Blocks library category in the Core Catalogs and click the beside it to expand its contents.  

    • Browse to CAD Blocks> Detail Components> Footings and Slabs, where a selection of footing and slab components are available.  

    • Click on a component to select it.  In this example, the Concrete Footing is used.  

    • When you move your cursor into the drawing area, it displays the CAD Block icon.  Click once to place the selected CAD block in your CAD Detail window.    

       


  3. In order for this item to be added to the library, it was made into a CAD block.  To edit it as a CAD object, click the Select Object tool, then click on the footing to select it, then click the Explode CAD Block edit button.   


  4. Click on the footing to select it again and click the Open Object edit button. On the Fill Style panel of the Polyline Specification dialog:    



    Select Concrete from the Fill Pattern drop-down list.  

    Specify the desired SpacingAngleLine Weight and Fill/Pattern Color.  

    On the Line Style panel, select a Line ColorStyle and Weight.  

    Click OK to close the dialog and apply your changes.

  5. When the CAD Detail is finished, select all objects in the CAD Detail and then click the Make CAD Block  edit button, then click Add to Library  to add the block to the library for future use. This CAD Block can also be copied and pasted into another CAD Detail, plan, or elevation view.



To draw components manually

Depending on your requirements for a particular detail drawing, you may find that you use all of the CAD Tool families:  Lines, Arcs, Splines, Boxes and Circles.  In this example, we will focus on closed polylines; however, nearly all of the concepts apply to open polylines, as well.

Two of the Box Tools; Rectangular Polyline and Box, seem very similar at a glance but are actually quite different from one another:

 

Rectangular Polylines are composed of lines, just as their name implies, so each of their edges can be edited in the same way that lines can:  they can be broken, trimmed, curved, deleted and so on.

 

Boxes are always closed shapes with four 90 degree corners.  Their corners can be filleted or chamfered but their edges cannot be extensively edited.  Boxes are useful when the item being drawn needs to remain a closed shape with right angles.  For this reason, framing cross boxes and insulation are created using Boxes.  

  1. Select CAD> Boxes> Rectangular Polyline from the menu, then click and drag a vertical rectangle to form the foundation stem wall.   

    • Don't worry about the exact size or location as you draw it:  instead, use Temporary Dimensions  to resize it precisely once it is drawn.  

    • In this example, a stem wall 8" wide and 24" high is used.  

    • To place the stem wall precisely, see To accurately position components, below.  


  2. With the rectangular polyline still selected, click the Open Object edit button.  On the Fill Style panel of the Polyline Specification dialog:    

    • Select Concrete from the Fill Pattern drop-down list.  

    • Specify the desired Spacing, Angle, Line Weight and Fill/Pattern Color.  

    • On the Line Style panel, select a Line Color, Style and Weight.  

    • Also on the Line Style panel, under Drawing Group, select which drawing group the polyline should be drawn on. The polyline will be displayed in front of any objects in drawing groups that are lower on this list.
      Note: in Chief Architect X8 and prior versions, there were only three drawing groups to choose from; Back, Default, and Front Group. Move to Front of Group could be checked to have the selected object be displayed in front of all other objects located in the same group. 

    • Click OK to close the dialog and apply your changes.  


  3. In this example:  

    • The CAD> Circles> Circle tool is used to create rebar in the footing and stem wall concrete.  

    • The CAD> Boxes> Cross Box tool is used to create framing members.  

    • The CAD> Boxes> Insulation tool is used to create sections of insulation in the floor and wall.  

    • The CAD> Lines> Draw Line tool is used to represent the grade line.  

    • Polylines are edited using Break Line , Change Line/Arc and other edit tools to create irregular shapes of the ground and drainage areas.   

    • The Leader Line tool is used to create annotations.  (In Version 10 and prior, the Text with Arrow tool can be used.)

      Note: In Chief Architect X8 and newer, when you select the Break Line tool, if you want to add more than one break at a time, click the Sticky Mode  tool.


To accurately position components

In Chief Architect, there are a number of ways to position objects precisely.  When preparing a detail drawing, three of the most useful tools are the CAD Stops Move specification, the Point to Point Move, and Transform/Replicate Object edit tools.  

CAD Stops Move is an option found on the Line Style panel of the specification dialogs of Text and closed CAD objects such as circles, polylines and boxes.

  • Check this box to enable this behavior for the selected object, and it will bump against other open and closed CAD objects when it is being moved, preventing them from overlapping.   

  • A quick way to align text objects is to draw a line and then, after checking CAD Stops Move in the text object's specification dialog, move the text so that it stops against the line, which can later be deleted.  

To learn how to use the Point to Point Move edit tool, see the Point to Point Move article listed in the Related Articles section.


Objects can be copied at regular intervals using the Transform/Replicate Object dialog using the steps below.

  1. Click on an object such as a 2x12 joist to select it, then click the Transform/Replicate Object  edit button.  


  2. In the Transform/Replicate Object dialog:   



    • Check the box beside Copy and specify the number of copies you want to make.  

    • Check the box beside Move and specify the increments that you want the copies to be placed on the appropriate Delta, or axis.  

    • Click OK to close the dialog and create the specified copies.  

    • In this example, two copies are placed at 16" intervals, or 16" on-center, along the X Delta.  


  3. The Transform/Replicate Object  edit button is also available when objects are group selected.  In this example, a 2x12 and a section of insulation could be Shift+selected, then replicated at 16" intervals as needed to quickly detail an entire floor platform.  




To place a detail drawing in a cross section view

  1. Open the cross section view that you would like to add detailing to, or create a new cross section view.


  2. Select CAD> CAD Detail Management , then select the CAD Detail you would like to add to the cross section view, and click Open

  3. With the Select Object tool active, hold down the Shift key on your keyboard and click and drag a rectangular selection marquee around your entire detail drawing.  When you release the mouse button, the entire drawing is selected as a group.  


  4. Click the Make CAD Block edit button to block the drawing into a single object.  


  5. With the blocked drawing selected, click the Copy/Paste edit button.  


  6. Select Window> Select Previous Tab to return to your cross section view.  


  7. Select Edit> Paste> Paste from the menu, then click once in the drawing area to place a copy of the blocked detail drawing.  


  8. You can now use the Point to Point Move edit tool to place the detail over the cross section at the appropriate location.

     

To add a drawing to the library

You can add a finished detail drawing or any portion of the drawing to the library by first blocking the objects in question using the Make CAD Block edit tool. Examples of items you might want to add are a group of stacked lap siding components, a custom connector or anchor bolt that you have drawn, or footing and stem wall with rebar.

  1. Select the CAD Block, then click the Add to Library edit button to add the drawing to your Library Browser, where you can then rename it and move it into an appropriate folder in your User Library.

    In Chief Architect X2, the Add to Library edit tool would place the Item in the Import category, where it then needed to be renamed and moved into the appropriate User Libraries folder.


  2. This CAD block is now available for use in any plan.

    Note: If you want to add an entire cross section view to your library as a CAD Block, you will first need to convert that cross section view into a CAD Detail by selecting CAD> CAD Detail From View. Then you can select the components of the newly created CAD Detail and make them a CAD Block to be added to your library.



To show shadows in a cross section view

In Chief Architect X8 and newer, you can now show shadows in a cross section view. To do this, select 3D> Camera View Options> Final View With Shadows .