Creating and Using a Plan Template


Reference Number: KB-00463
Last Modified: March 16, 2017

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors

QUESTION

I have a number of different architectural design styles that I often use and would rather not have to set up my default settings every time I begin a new plan that will use one of these styles.  How can I do this work once and save it for future use?


ANSWER

In Chief Architect, any time you open a new, blank plan, its initial default settings are copied from a template.  You can create your own custom template plans to reflect the architectural styles, annotation sets, and materials that you use most often.

A template plan is essentially a blank plan with default settings customized to meet a particular set of design needs.  You may find it helpful to create more than one template, each set up to draw a particular architectural style.  It is a good idea to save all your templates in a particular location, such as a folder in My Documents or in the Chief Architect Templates directory.

If migrating forward to the current version of Chief Architect from an older version, please make sure to follow the instructions in the Migration Guide, located in your Digital Locker.


To create a template 

While it is a good idea to go through all of the defaults to make sure the template is setup exactly how you need it, there are some defaults that are more critical to change ahead of time, as they can be troublesome to change after the design is complete. It is recommended that these "Critical Defaults" are set up in the template and reviewed before starting any plan.

Begin by selecting File> New Plan  from the menu to open a new, blank plan using the default profile.plan template.

Critical Defaults

All default settings are important. Form a habit of setting the defaults for an item prior to placing them in the plan. 

You can also set up layer sets in your template file. A layer set consists of a complete list of the layers in the current plan or layout along with the display settings for each layer as set for a particular type of view or purpose. These display settings can be modified, and can be different for each layer set. Please review this resource on layer sets for more information:How to User Layer Sets

Saving


Annotation Set Defaults*

*Chief Architect Premier only

Annotation Sets are simply a fast, easy way to switch from one collection of Saved Defaults created for one particular purpose to another collection set up for a different task.

Annotation Sets include defaults for:  Dimensions, Text, Callouts, Markers, Arrows, the Current CAD Layer, as well as the Active Layer Set. Multiple Annotation Sets can be saved in any plan, each for a specific purpose, and you can quickly switch from one set to another as you work by using the Annotation Set Control on the toolbar.

In order to set up Annotation sets it may be necessary to create additional defaults for text, dimensions, CAD and layers.

A number of Annotation Sets are included in the template plans installed with Chief Architect. You can use these sets as they are or customize them, and you can also create additional new sets in both plans and layouts.

To set up Annotation Sets

  1. From the menu select Edit> Default Settings .


  2. From the list provided select Annotation Sets and then click the Edit button.




  3. In the Annotation Sets dialog, notice the pre-defined Annotation Sets on the left. The following options are available:

    • Select an Annotation Set to view or modify it's saved defaults.

    • Select one that has similar properties to the one you want to create and click Copy to make a copy of it before modifying.

    • Click New to create a new Annotation Set based on the primary 1/4" Scale Annotation Set.

    • Select an unnecessary Annotation Set and click Delete to remove that set from the list.


  4. On the right side of the Annotation Sets dialog choose the saved defaults for the selected Annotation Set.

    • Give the Annotation Set a Name.
    • Set the Current CAD Layer - When you draw a CAD item that item will be placed on the layer specified as the Current CAD Layer for the selected Annotation Set.
    • Choose from the existing defaults for Dimensions, Rich Text, Text, Callouts, Markers, and Arrows or you can Add , Edit , or Delete  those defaults.  Keep in mind that deleting a default in the Annotation Sets dialog will delete it from the Default Settings entirely.

To set up Annotation Sets, you should review the online tutorial training videos on the Annotation Sets feature, as well as the Knowledge Base article on Annotation Sets.


Text Styles

In Chief Architect, a Text Style is a saved set of attributes that can be assigned to any object that displays text, such as Text, Callouts, Markers, Dimensions, Schedules, CAD objects, and object labels. This makes it easy to ensure that various objects display text with a consistent appearance. You can create your own or edit existing Text Styles to suit your needs.

To Set Up Text Styles

  1. From the menu select Edit> Default Settings .


  2. Expand the list for Text, Callouts and Markers. Next select Text Styles and click the Edit button.




  3. In the Saved Text Styles dialog, a list of text styles that are already set up displays.

    • Choose a saved text style and click the Edit button to modify the text style.

    • Chose a saved text style and click Copy to create a new text style based on the settings of the chosen text style.

    • Choose a saved text style and click Rename to rename that text style.

    • Choose a saved text style and click Delete to remove that text style.

In Chief Architect Premier X9 it is possible to group select multiple text defaults. For example it is possible to group select all the text styles and change their font.


Dimension Defaults

There are several saved dimension defaults. These defaults are associated with the annotation sets mentioned at the top of this article. Having multiple defaults allows you to switch between them to have the dimensions change their behavior when you are dimensioning for different views. For example you can have dimensions location the framing layer of the walls for your framing plans and the interior surface of the walls for your interior design plans. Another example would be specifying a different sized text style for your plot plan vs a smaller sized text style for interior elevations.

To set up Dimension Defaults

  1. From the menu select Edit> Default Settings .


  2. Expand the list for Dimension. Next, select Dimensions and then click the Edit button.


  3. A list of Saved Dimension Defaults opens. The currently active dimension default is highlighted in the list as well as being specified at the bottom of the dialog.




  4. Select the default that needs to change and then click Edit to open the saved default. Review these setting to verify that they meet the needs of your projects. The most commonly changed settings are as follows:

    • On the Primary Format panel specify the desired Units.

    • On the Locate Objects panel specify which objects you want the dimensions to locate.

    • On the Layer panel specify which layer these dimensions should be on.

    • On the Text Style panel specify which Text Style Default these dimensions should use.


  5. Complete these steps for all Dimension Defaults in the template.

         *Keep in mind, the Auto Dimension defaults (Auto Exterior, Auto Interior, Auto Elevation, etc.) apply only when the corresponding auto dimension tool is used.

    If you want to have the Manual Dimensions locate interior wall surfaces set the Dimension Default to locate "Surfaces" and "Both Wall Sides" on the Locate Objects panel.

    It is recommended that Temporary Dimensions reflect the same settings as Manual Dimensions so be sure to have  "Locate Wall Surface" and "Locate Both Wall Sides" selected for Temporary Dimensions as well as "Locate Wall Surface" and "Automatic" under the With Wall Opening Selected section. 


Floor and Ceiling Structure Defaults

the floor and ceiling Structure defaults consist of the layers that make up the floor and ceiling platforms. For example the floor joists and sheathing or the ceiling joists. This is also where the Floor and ceiling finishes are set. These settings can be leveraged to create Suspended ceilings, choose the type of floor framing (lumber, i joist, steel, concrete, etc.). As well as specify the energy values for REScheck export.

To set up Floor and Ceiling Structure Defaults

  1. From the menu select Edit> Default Settings.


  2. Expand the list for Floors and Rooms and then select Floor/Ceiling Platform and click Edit.


  3. In the Floor/Ceiling Platform Defaults dialog choose which platform settings to modify and then click the Edit button next to that setting.

    • Ceiling Structure typically contains just a layer for ceiling joists

    • Ceiling Finish typically contains a layer for the drywall and a layer for the paint color.

    • Floor Finish typically contains a layer for the floor finish as well as any layers for underlayment.

    • Floor Structure typically contains a layer for the floor sheathing and a layer for the floor joists.


  4. In this example the Floor Structure Edit button is clicked and in the Floor Structure Definition dialog, the Layers, Materials, Energy Values and diagram of the floor structure is displayed.



    • Layers -The layers of the floor or ceiling platform structure definition are listed here.

      • Layers are numbered and listed from the top of the structure to its bottom.
      • To select a layer for editing, click on it in the structure diagram at the bottom right of the dialog: the arrow to the right of the diagram points to the selected layer. You can also select a layer by clicking its Thickness text field.
      • Use the Insert and Delete buttons to add or remove layers in this structure.

      The Insert button creates a new layer directly above the currently selected layer. To insert a layer at the bottom of the structure, click on the bottom line in the structure diagram at the bottom right of the dialog. The arrow to the right of the diagram points to the active layer.
    • Selected Layer - Specify the characteristics of the selected layer.

      • A preview of the selected layer's Fill Style is shown. Click the preview or the Fill Style button to specify the fill style created when the Auto Detail tool is used in a cross section view.
      • Previews of the selected layer's material display above the Select Material button. Click either the preview or the Select Material button to open the Select Library Object dialog to choose a different material.
      • A diagram of the Material Layers assembly displays below the Selected Layer settings. To select a layer, click on a layer in the diagram. The arrow to the right of the diagram points to the Selected Layer.

    • Energy Values -Specify the Energy Values of the selected Floor or Ceiling Structure. Not available for any object or component types other than Floor and Ceiling Structures.

      • Specify the structure’s Cavity R-Value, which is the R-value of its cavity insulator: most commonly, the insulation between wood or metal joists.
      • Specify the Continuous R-Value, which is the R-value of continuous insulators such as rigid foam sheets.


Floor and Ceiling Height Defaults

Many important default values that affect rooms are specified in the Floor Defaults dialog for each floor in a plan. This dialog controls important information that the program uses to create a 3D model - particularly floor and ceiling heights and materials. Moldings can also be specified in the Floor Defaults dialog.

Only the defaults for the first floor of a building can be set ahead of time. The program uses the setting from the first floor to create subsequent floors. When a new floor is created, its floor defaults are displayed and can be changed at that time.

To set up Floor and Ceiling Height Defaults

  1. Select Edit> Default Settings  from the menu to open the Default Settings dialog.




  2. Expand the list for Floors and Rooms and then choose Current Floor

    In prior versions select
    Floor and click the Edit button. 


  3. On the Structure panel of the Floor 1 Defaults dialog, specify the default Ceiling (B) height for Floor 1.
     
  • Ceiling (B) and Rough Ceiling (E) represent framing dimensions from the bottom of the wall bottom plate to the top of the wall top plate.

  • The default Floor Height for Floor 1 is set at 0".
    Note: Chief Architect always defines the default height of Floor 1 at 0’-0”. This height value is measured from the top of the subfloor and is the constant by which the heights of structural elements in the program like walls, floors, and ceilings are measured. The heights of architectural objects can be measured relative to this absolute height, as well. As such, this default cannot be changed.

  • Finished Ceiling (F) represents the dimension between the the floor finish and the ceiling finish.



    At the bottom of the Structure panel there is a setting for Monolithic Slab Foundation. If a foundation plan is desired do NOT put a checkmark in this setting. Instead, choose Monolithic Slab in the Build Foundation dialog or the Foundation Defaults prior to building the foundation (Build> Floor> Build Foundation). If Monolithic Slab Foundation is checked, the current Floor Structure will be replaced by a single 4” (100 mm) layer of concrete with footings that can be seen in camera views only.

  • On the Moldings panel:

    • The Profile template will have one molding already set up for Base Molding. 

      • If you want to remove the molding choose Delete.
      • If you want to add additional moldings, Click on Add New.
      • If you want to replace the existing molding with a new one choose Replace.

    • In the Select Library Objects dialog, browse to find a molding profile that meets your needs and click OK.

    • Specify the dimensions of the molding such as Height and Width, the Type of molding and the Distance From Floor for each molding profile.




  • When you are satisfied with your selections, click OK.


  • To set up Framing Defaults

    1. In the Default Settings dialog select Framing and click the Edit button.


    2. In the Framing Defaults dialog, on the Foundation panel specify the Spacing and Joist Width listed for the Subfloor for Floor 1


    3. On the 1st panel specify the Spacing and Joist Width for the Ceiling Above Floor 1 as well as the Subfloor for Floor 2


      Notice that the Floor Structure and Ceiling Structure matches what is specified in the Floor/Ceiling Platform Defaults section specified earlier.

    To set up Wall Type Defaults

    1. In the Default Settings dialog:

    • Expand the list for Walls.

    • Select Exterior Wall and click the Edit button.


  • In the Wall Defaults dialog, specify the desired wall types that you would like to use, on the Wall Types panel, whenever the Exterior Wall tools are used.


  • Click the Define button if you would like to create or modify a custom wall type in the Wall Type Definitions dialog.

    • In addition to specifying structural aspects of a wall, such as its framing and sheathing, you can specify siding material such as lap siding, shingles or stucco and interior materials including paneling, finished tongue and groove, and sheetrock.


  • Repeat steps 2 and 3 to define the defaults for Interior WallFoundation Wall, upper and lower Pony Wall, as well as Half-Wall tools.


  • You can also specify Railing, Deck Railing and Fencing Defaults. 

    • The Railing, Deck Railing and Fencing Defaults dialogs are similar to the Railing, Newels/Balusters, Layer and Materials tabs of their corresponding specification dialogs.  A variety of attributes can be specified here, including railing construction, newel and baluster size, style and spacing, and materials.


    Saving and using a style template

     

    To save a template

    1. Select File> Templates> Save As Template .


    2. Give the new template a short, descriptive name. Be sure to delete the asterisk (*). This automatically saves the template to the Chief Architect Templates folder.


    3. A popup message will display "Do you want to use this file: (template name.plan) as your default template for imperial (or metric) plans?"

      Choose Yes if you want to use this template as the default or No if you want to use a different template as your default.




    4. To choose a different template to create a new plan, select File> Templates> New Plan from Template .


    5. Select the template from the list and click OK.


    To use this template whenever you open a New Plan file

    To set the default template whenever you open a New Plan file, specify it as your template in the Preferences dialog. 

    1. Select Edit> Preferences  from the menu to open the Preferences dialog.

      On a Mac, choose Chief Architect> Preferences .


    2. On the New Plans panel of the dialog, click the Browse button to the right of the Plan Template text field.




    3. In the Select a Plan Template File dialog, browse to the location of your new template file and click Open to specify this file as your plan template.


    4. Click OK to close the Preferences dialog and apply your change.