Setting up a Custom Default/Annotation Set


Reference Number: KB-01167
Last Modified: March 26, 2020

The information in this article applies to:

Chief Architect Premier



QUESTION

I would like to create a custom set of defaults for my dimension and text objects. How can I accomplish this task using Default/Annotation Sets?  


ANSWER

While most objects in Chief Architect have one defaults dialog that affects all objects of that type in a given plan, there are some that support multiple sets of defaults rather than just one.

A Default/Annotation Set is a collection of Saved Defaults for many of the tools used to annotate plan and layout files: manually-drawn Dimensions, Text, Revision Clouds, Callouts, Markers, Notes, Arrows, the Active Layer Set, and the Current CAD Layer. Multiple Default/Annotation Sets can be saved in any plan or layout, each for a specific purpose, and you can quickly switch from set to set as you work on these various tasks.

Default/Annotation Sets can be set up for different drawing tasks with specific annotation requirements. For example, you could create a set for site plans with large dimensions, text, callouts, markers, and arrows; a dimension format using feet, yards, or meters instead of inches or millimeters; and custom layers for dimensions and text.

In this article, a custom Default/Annotation Set is created in a new, blank plan. We then explain the basics of customizing a Default/Annotation set and finally, how to export the Default/Annotation Set and import it into another file. 


To create a new Default/Annotation Set

  1. Launch Chief Architect and create a New Plan .


  2. Select Edit> Default Settings , highlight Default Sets or Annotation Sets, then click the Edit button.

    Select Default/Annotation Sets in the Default Settings dialog

    Annotation Sets were renamed to Default Sets starting in Chief Architect X12.


  3. In the Default/Annotation Sets dialog that opens, select a default/annotation set that closely matches what you're wanting to create, then click the New button.

    In X11 and prior program versions, select the Copy button instead.


  4. In the New Default Set dialog that displays, provide a Name, then click OK.

    Provide a Name for the new Default/Annotation set

    In X11 and prior program versions, the Name can be changed in the Annotation Sets dialog.


To customize a Default/Annotation Set

Now that we have created our new Default/Annotation Set and see it displayed in the Name field, we are ready to customize it.

  1. Next to Dimensions, click on the green New Default  button to create a new dimension default.

    • In the New Default dialog that displays, specify a Name and click OK.

      New Default dialog where a Name can be specified.

      In this example, 3/4" Scale Dimension Defaults was specified for the name.

    • Next, in the new Dimension Defaults dialog that appears:

      Primary Format of the new Dimension Default that was created

      • Select the Primary Format panel, and make any desired changes to how the dimensions will be displayed.

        In this example, the Units is set to " (Inches) and the Smallest Fraction is set to 1/32.

      • On the Locate Objects panel, specify how you would like dimensions to locate walls and check/uncheck what objects dimensions will locate.

        In this example, Surfaces and Both Wall Sides are selected, and under the Openings heading, the Casing box is checked.

      • On the Layer panel, click the Define button to open the Layer Display Options dialog and create a new layer to be used for Interior Dimensions.

        In this example, a new layer called Dimensions, Interior was created.

      • Once you have completed making changes in this dialog, click OK.


  2. Continue on through setting up the defaults for Rich Text, Text, Revision Clouds, Callouts, Markers, Notes, and Arrows.

    Default Sets dialog with a new Default Set that has been setup


  3. Just as with the Dimension Defaults that were mentioned in Step 1, important considerations for each Saved Default include:

    • The layer each object type is placed on.

    • That layer's properties.

    • Sizing and other information set in the defaults dialog.


  4. In the Default/Annotation Sets dialog shown in Step 2 above, notice that the Current CAD Layer can be adjusted, either by selecting the Current CAD Layer from the drop-down list, or by clicking the Define button.

    Current CAD Layer has been changed in Default Sets dialog

    In this example, a new layer was created called CAD, Interior


  5. After you have set up all of the defaults for the new Default/Annotation set, click OK, then Done to close the dialog boxes.


  6. You can now set up your Saved Plan Views to utilize this new Default/Annotation set. Once you have spent the time creating and customizing Default/Annotation Sets, you may also want to make them available for use in another plan or your plan template file. Proceed to the next section to learn how to export and import Default/Annotation Sets between plan files. More information on creating a custom plan template can be found in the Related Articles section below.


To move a custom Default/Annotation Set into another plan

  1. Select File> Export> Export Default/Annotation Sets to open the Export Default/Annotation Sets dialog.

    Export Default Sets File dialog

    • Choose an easy to find location, such as your Desktop.

    • In the File Name field, type in a short, descriptive name such as the name of the Default/Annotation Set, then click the Save button to save the *.cadefs file.

      Note that this will export all Default/Annotation Sets in the current plan file.


  2. Select File> Open Plan to open the plan or template in which you want to import your custom Default/Annotation Set.


  3. Select File> Import> Import Default/Annotation Sets  and navigate to the Desktop, or wherever you chose to save your exported Default/Annotation Set files.


  4. Click on the file to highlight it, then click Open.


  5. Choose your desired options in the Import Default Sets dialog, then click OK.

    Import Default Sets dialog


  6. Once the Default/Annotation Set files have been imported, an Information dialog will appear detailing what has been imported. Click OK.


  7. Select File> Save or File> Templates> Save As Template  if you've imported Default/Annotation Sets into your plan template. 


  8. To switch to a different Default/Annotation Set while working in a project, you will want to utilize Saved Plan Views.