Troubleshooting Slowness in Chief Architect Plans


Reference Number: KB-00521
Last Modified: August 17, 2016

The information in this article applies to:

Chief Architect Premier or Chief Architect Interiors

QUESTION

I am working on a large plan, and I notice that the program is working very slowly, is sluggish or seems to lag. Is there something that can be done to remedy this?

ANSWER

In this article, we will discuss the most common reasons for encountering slowness in Chief Architect plans starting with the most common issues

Please make sure to review all of the information in this article, as the cause of slowness that you may be encountering could be related to more of the items listed below.



Work on Files Locally

By far, the most common reason for Chief Architect to run slowly is working in an unsupported fashion, such as over a network server location, external hard drive, or USB flash drive device.

DO NOT WORK ON FILES OVER A NETWORK OR USB FLASH DRIVE DEVICE.


In addition to experiencing slowness working in files, working in this type of unsupported fashion is hazardous because it can lead to file corruption and data loss.

For these reasons, it is critical always to work on files that are saved on your local hard drive. This means that you should copy the file from a network server, external hard drive, or USB flash drive device's location to your computer's hard drive before opening it in the software.  Then, make your changes, save the file, exit the program, and then copy the file back to its network server, external hard drive, or USB flash drive device location. 

If you are working on your computer's hard drive, with file's being saved as recommended in the 
Guide to File Management, and are still experiencing slow plans, then please continue with the information provided in this article.

There are a number of things that you can do to speed up the drawing process when working on a large plan that is saved on your computer's hard drive.  We'll go through each of these in order of importance, starting with the most common reasons you may be experiencing slowness in a plan.


Verify System Requirements

If you are working on files locally, the next step is to verify that your computer meets, or better yet, exceeds, the minimum system requirements for running your version of Chief  Architect.

The system requirements for the current version of the software can be located online at: https://www.chiefarchitect.com/products/sysreq.html

  • If you have a 64-bit system, make sure you have installed the 64-bit version of the current Chief Architect software program.

  • If you primarily notice slowness with regards to 3D Camera views, check to see how much dedicated video memory is on your video card. 

    If it only just meets the minimum, then you may want to look into replacing it with a video card which has more memory.

    Note that the recommended system requirements call for a gaming card, and you may experience slower performance with other video cards or integrated chipsets.

    Please note that an integrated chipset, such as those produced by Intel, which shares system memory, does not meet the minimum system requirements for running X5 or earlier versions of the software, and requires a driver from 2014 or newer which is compatible with your operating system for X7 and X8.

  • Update your video card's driver to the most recent version compatible with your operating system by following the instructions in the Knowledge Base article on Troubleshooting 3D Camera View Display Problems, then verify that the appropriate card and driver are listed in Chief Architect's Preferences under Video Card Status.

  • If you are using multiple monitors, make sure that your system's video card fully supports this functionality.

    You may experience slowness, particularly with 3D camera views as well as library and dialog previews if the video card is taxed by three or more monitors as well as the rendering.  You can test shutting the system down, disconnecting the extra monitors, restarting the system, and then attempt to run Chief Architect on a single screen to see if speed improves.

  • Slowness can be potentially encountered when running Chief Architect full screen on an iMac with a 5K monitor. Reduce Chief Architect's window size so that it is not full screen and continue working to see if performance is improved.

  • If you are looking into purchasing a new system and want to make sure that it offers good performance in Chief Architect, on the System Requirements page, scroll down and review the recommended requirements, not just those that are the minimum, and also pay particular attention to the Tips for Buying a New Computer section.

    Check your potential hardware purchase against the benchmark websites listed on the System Requirements page, and also check the ChiefTalk user forum for current computer recommendations from other users.

  • Make sure to close any other programs running in the background on the computer which may be taking up system resources, if they are not needed, while working in the complex plan and/or layout experiencing the slowness.



Simplify Fill Styles and Patterns

Avoid using complex fill styles and patterns extensively in your plan and CAD Details.

  • If you use a custom Fill Style that requires drawing many tiny lines on the screen, this can substantially slow down working in floor plan view for such tasks as zooming, moving and placing objects.

    Particularly for elements of your design such as the layers of your wall type definitions, roof planes, closed polylines, rooms, and landscaping features, try to avoid the use of many fill patterns.

  • Material patterns, such as complex stone or tile patterns, in views which utilize the Vector rendering technique, such as Cross Section/Elevations and Orthographic Overviews, will also slow down the generation of the view as well as actively working in it.

  • If you must add these types of detailed CAD elements for hatching and fills to your design, make sure to do so as one of the final steps when your plan is near completion, before creating the layout, and expect to encounter slowness with the file after doing so.



Slowness in 3D Views

  • Avoid working with multiple 3D camera views open. Every time you make a change to the plan, the program will redraw the entire model.  Depending on the complexity of the design, this may take a long time.

    You can see how many view windows are opening by selecting the 
    Window menu. Open view windows are listed at the bottom of the menu.

    If you are using the Generated Sky setting, keep in mind it takes into account the orientation of the sun, so if you've set the sun to follow your camera, then the generated sky will regenerate each camera movement to account for the new sun direction, which can cause slowness in 3D camera views.
     

  • Manage Displayed Layers - If you need to work in 3D views, turn off any layers that aren't necessary for the task.  This will improve your redraw time.

    For example, if you need to work on landscaping or roofs in a Full Overview, consider turning off the layers for Fixtures and Furnishings in the Camera View or Section View layer sets.

    You can even create new layer sets with these layers turned off, and use them as your default when new camera views are created.

    In elevation and plan views, if you use a high number of macros in text or labels that are displayed, this can slow down panning, zooming, and moving objects in these views.
     

  • Manage 3D Surface Count - Avoid importing 3D objects from outside sources that have a large number of complex surfaces, as these can significantly slow down camera views.

    To check the number of surfaces for imported symbols, using the Select Objects tool, click on an imported symbol to select it.  Next, click on the Open Symbol edit button to display the Symbol Specification dialog.  On the 3D panel, take note of the Number of Faces and then Cancel out of the dialog without making any changes.



    If you aren't certain whether or not a symbol has an unusually high number of faces, you may want to repeat this procedure on a similar type symbol placed from the Chief Architect catalogs and compare the Number of Faces.



Control Pictures and PDF files Saved in Plan/Layout

By default, picture files and PDF files are referenced from outside of your Chief Architect file.  You can, however, open the Specification dialogs for both of these types of objects and check the Save in Plan option to embed the picture, or PDF, in the plan.  If you chose this option, it could cause a significant slowdown when working in the plan or layout file.

Instead of saving pictures or PDF files in the plan, the recommended method for transferring a file between computers, or to another individual, is to use the Backup Entire Plan  feature to ensure that no data is lost that would result in a missing file message.  This feature not only allows you to export the picture and PDF files along with the plan and layout, but also all of the associated custom backdrops, materials, and images you may be using for the file. For more information on using the backup entire plan tool, see the Related Articles section at the end of this article.




Manage Live Views in your Layout

When you send a cross section/elevation, camera view, or overview to your layout, you have the option to select Live View to make the view dynamically linked to the plan file.  You can also select for this view to Update On Demand, or Update Always.

Selecting Update Always can potentially contribute to slowness in your plan.
To change a view set to Update Always so that it only updates on demand, select the view in your layout, then click the Open Object edit button to open the Layout Box Specification dialog. On the General panel, under Camera View Options, select Update On Demand and then click OK.



Purge Unused Data

  • In addition to the suggestions above, if you have been using a file through several versions of Chief Architect, you may have unnecessary leftover data such as unused CAD Blocks, materials, and layer sets that can be removed to reduce the overall size of your plan file.

    Chief Architect does not recommend reusing plan files by deleting everything out of an existing plan file and renaming it using the Save As option. 

    It is important always to start a new plan or layout files from a template created in the current version of the software.  Please see the current version Migration Guide to learn more.

    If you are unfamiliar with setting up template files, please review the Template articles listed in the Related Articles section at the end of this article. 

  • To purge unused CAD blocks, select CAD> CAD Block Management  from the menu.  In the CAD Block Management dialog, there is a list of all CAD blocks referenced in your plan.



    Click the Purge button to delete any unused block definitions from the list.

    You can also click on an unused CAD block in the list, then click the Delete button to remove it from the list. 

    In Chief Architect X3 and newer, the Automatically Purge CAD Blocks feature is available. When checked, this feature will prevent unused CAD block definitions from being saved in the plan.

    Note: It is not possible to delete all CAD block definitions from a plan file. Even if no objects are present in the plan, the CAD blocks associated with default electrical symbols are saved with the plan and cannot be removed.

    When you are satisfied with the CAD block list, click OK to close the dialog and apply the changes, then Save the file.

  • To purge unused materials from your plan, select 3D> Materials> Plan Materials  from the menu to display the Plan Materials dialog.  The list on the left includes all materials present in the plan.  Click the Purge button on the right to remove any unused materials from the list. 



    You can also select an individual unused material from the list and click the Delete button. 

    When you are satisfied with the Plan Materials list, click OK to close the dialog and apply the changes, then Save the file.


  • To manage layer sets, select Tools> Layer Settings> Layer Set Management  to open the Layer Set Management dialog.  Use the Available Layer Sets options to manage the layer sets saved with the current plan or layout file.  Click on a layer set name in the list to select it. 



    Click the Delete button to delete the selected layer set from the current file.

    The Delete button is only enabled if the layer set can be deleted. You cannot delete the active layer set or any layer set in use as a default. 

    Do not delete any layer sets that are used in views sent to layout. 

    If you have a large number of layer sets named Layout Set #, please review the software's documentation on the Send to Layout dialog.  Generally, you should be using the currently active layer set when sending to layout instead of making a copy of it.

    When you are satisfied with the list of layer sets, click OK to close the dialog and apply the changes, then Save the file.



Disable Auto Rebuild Options

There are several settings within the program that affect rebuilding, which can slow down a complex plan if they are constantly having to be regenerated after every change.  For speed purposes, you may want to turn off these auto rebuild settings, and only turn them back on when the plan is close to completion.

  • Automatically Rebuild Foundation - This setting can be accessed by selecting Edit> Default Settings> Foundation on the Foundation panel.  Uncheck this option to stop the foundation from rebuiling every time you make a change on the first floor.  Please note that you will then have to manually update the Floor 0 level, or remember to turn the feature back on later in the design process.

  • Automatically Build Framing - There are several Auto Build framing settings, which can be accessed by selecting Edit> Default Settings> Framing.

    Go through every individual floor panel, starting on the Foundation, up to 1st, 2nd, etc and uncheck the checkboxes near the top of the dialog for Automatically Build Floor and Ceiling Framing.

    On the Wall panel, uncheck Automatically Build Wall Framing.

    On the Roof panel, uncheck Automatically Build Roof Framing and click OK.

  • Auto Rebuild Roofs - This setting can be accessed by selecting Build> Roof> Build Roof .  On the Roof panel, uncheck Auto Rebuild Roofs and click OK.

    Any future changes made to the plan while this setting is disabled will not affect the roof, so you will need to either modify or add roof planes manually, or wait until the plan is nearer to completion to turn the setting back on if it significantly slows down your ability to work in the plan.

  • If you have a complex terrain that requires rebuilding when you make changes, select 3D> 3D View Defaults .

    On the Options panel, uncheck Auto Rebuild Terrain.  When you click OK, you will notice that your mouse cursor now has an image of the Rebuild Terrain setting following it to remind you that your terrain may not be up to date.

    You can also turn off Auto Rebuild Walls/Floors/Ceilings at this location.  While this may speed up changes you make to your plan, it is extremely important to remember that it also means that your 3D camera views may not accurately reflect changes that you have made to the plan view.

    You can disable this setting for troubleshooting purposes, however, expect that when this is unchecked and the structure is not up to date, the Rebuild Walls, Floors, Ceilings icon will display next to your mouse pointer.

  • Again, if these changes offer speed improvement in working with your complex plan, you will need to remember to manually rebuild the various options, or to wait until the plan is near completion to turn the automatic settings back on.


Run a Diagnostic Memory Check

If your system meets or exceeds our minimum system requirements, it may be worth running a diagnostic memory check to see if there are any issues with your computer's memory. For information on running a diagnostic memory check, please view the appropriate link below based on your operating system.



ADVANCED TROUBLESHOOTING

If you have completed ALL of the troubleshooting steps listed in this article and still have not been able to determine the cause of the slowness in your plan, then please submit ALL of the following information to Chief Architect's Technical Support team for advanced troubleshooting.

To report the issue to Technical Support

  1. When you notice the slowness, take a moment to write down what you were doing.  Include what views you had open, what tools you were using, and what types of objects were being added, edited, or removed.

    For example, joining two particular roof planes, modifying a CAD Detail by breaking lines, editing doors/windows while a 3D camera view is open, rebuilding framing, etc.


  2. If the issue only seems to occur in one particular file, use the Backup Entire Plan  tool to create a folder with a copy of the file in which the error occurs, along with all referenced files.

    See Knowledge Base article Using the Backup Entire Plan Tool.


  3. If you are receiving an error or warning dialog box, make sure to first search this Knowledge Base for the exact wording of the error, or click on the Check Knowledge Base button in the message if one is present, as there may be specific information relevant to that error recorded in another article.  If you are unable to locate any additional information on the error, make sure to attach a screen capture image of the message.

    See Knowledge Base article Creating a Screenshot.


  4. Locate the Message Log.

    See Knowledge Base article Locating the Message Log.


  5. Export your System Information using the appropriate article below for your operating system.

    Windows - Finding Information About your System in Windows

    Mac
    - Finding Information About your System on a Mac


  6. Log in to the Online Support Center and create a new ticket to send to Technical Support.

    Online Support Center - https://support.chiefarchitect.com/


  7. Give the ticket a short but descriptive title.

    In the text of the ticket, type a detailed description of the problem, including the exact steps that caused the slowness to occur if at all possible. 
    The more detailed you are, the more likely we will be to reproduce the issue and identify the problem.

    Click the Browse button and attach the Backup, Screenshot,  System Information,
    and Message Log files to your ticket, then Submit it.

    It is possible that Technical Services may need additional information regarding the issue, which they will request via a reply in the Online Support Center.

    Note: Some of the requested information may identify you, as well as specific information about your computer, but it will also help us determine the source of the problem. Please be assured that any files submitted to Chief Architect Technical Support will be used for troubleshooting purposes only.